【EIGRP】名前付きモード(Named Mode)の設定

EIGRP

IOS15系では、EIGRPの設定方法として、名前付きモード(Named Mode)がサポートされています。(従来の設定方法はクラッシックモードと呼ばれます)

従来のクラシックモードでは、例えば、グローバルレベル設定(router eigrp)とインタフェースレベル設定(interface)が分かれていました。しかし、これらが、名前付きモードにすることで、グローバルレベル設定に統一されます。

また、IPv4とIPv6の設定もグローバルレベル設定で統一され、これらを区別するために、アドレスファミリーを設定する必要があります。

スポンサーリンク

仮想インスタンスの設定

クラシックモードでは、router eigrp コマンドの後にAS番号を定義しましたが、名前付きモードの設定では、仮想インスタンス名を定義します。

R2(config)# router eigrp ?
  <1-65535>  Autonomous System
  WORD       EIGRP Virtual-Instance Name

この名前はローカルで一意である必要があります。ネイバーと合わせる必要はありません。ここでは、Named-EIGRP と設定します。

R2(config)# router eigrp Named-EIGRP
R2(config-router)#

するとconfig-router モードに移行します。

スポンサーリンク

アドレスファミリーとAS番号の設定

次にアドレスファミリーを設定します。

R2(config)# router eigrp Named-EIGRP
R2(config-router)# ?
Router configuration commands:
  address-family  Enter Address Family command mode
  default         Set a command to its defaults
  exit            Exit from routing protocol configuration mode
  no              Negate a command or set its defaults
  service-family  Enter Service Family command mode
  shutdown        Shutdown this instance of EIGRP

アドレスファミリーのヘルプを確認すると、ipv4ipv6 のどちらかを選択できます。

R2(config-router)# address-family ?
  ipv4  Address family IPv4
  ipv6  Address family IPv6

今回はipv4のため、ipv4と入力し、ヘルプを確認します。

R2(config-router)# address-family ipv4 ?
  autonomous-system  Specify Address-Family Autonomous System Number
  multicast          Address Family Multicast
  unicast            Address Family Unicast
  vrf                Specify a specific virtual routing/forwarding instance

今回はユニキャストを選択します。

R2(config-router)# address-family ipv4 unicast ?
  autonomous-system  Specify Address-Family Autonomous System Number
  vrf                Specify a specific virtual routing/forwarding instance

次にAS番号が設定できます。AS番号=100と設定します。

R2(config-router)# address-family ipv4 unicast autonomous-system 100
R2(config-router-af)#

AS番号を設定した後、エンターキーを入力すると、config-router-af モードに移行します。afとはaddress-family の略です。 ヘルプを確認すると、この中で様々な設定ができることを確認できます。

R2(config-router)# address-family ipv4 unicast autonomous-system 100
R2(config-router-af)# ?
Address Family configuration commands:
  af-interface         Enter Address Family interface configuration
  default              Set a command to its defaults
  eigrp                EIGRP Address Family specific commands
  exit-address-family  Exit Address Family configuration mode
  help                 Description of the interactive help system
  maximum-prefix       Maximum number of prefixes acceptable in aggregate
  metric               Modify metrics and parameters for address advertisement
  neighbor             Specify an IPv4 neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  shutdown             Shutdown address family
  timers               Adjust peering based timers
  topology             Topology configuration mode

インタフェースレベルの設定

af-interface では、従来のインタフェースレベルの設定ができ、様々なインタフェース種別が選択できます。

R2(config-router)# address-family ipv4 unicast autonomous-system 100
R2(config-router-af)# af-interface ?
  Async              Async interface
  Auto-Template      Auto-Template interface
  BVI                Bridge-Group Virtual Interface
  CDMA-Ix            CDMA Ix interface
  CTunnel            CTunnel interface
  Dialer             Dialer interface
  FastEthernet       FastEthernet IEEE 802.3
  GMPLS              MPLS interface
  Group-Async        Async Group interface
  LISP               Locator/ID Separation Protocol Virtual Interface
  LongReachEthernet  Long-Reach Ethernet interface
  Loopback           Loopback interface
  MFR                Multilink Frame Relay bundle interface
  Multilink          Multilink-group interface
  Port-channel       Ethernet Channel of interfaces
  Tunnel             Tunnel interface
  Vif                PGM Multicast Host interface
  Virtual-PPP        Virtual PPP interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  default            Address-family default interface configuration
  vmi                Virtual Multipoint Interface

例えば、FastEthernet0/0.23 を選択し、ヘルプを確認します。

R2(config-router-af)# af-interface fastEthernet 0/0.23
R2(config-router-af-interface)# ?
Address Family Interfaces configuration commands:
  authentication      authentication subcommands
  bandwidth-percent   Set percentage of bandwidth percentage limit
  bfd                 Enable Bidirectional Forwarding Detection
  dampening-change    Percent interface metric must change to cause update
  dampening-interval  Time in seconds to check interface metrics
  default             Set a command to its defaults
  exit-af-interface   Exit from Address Family Interface configuration mode
  hello-interval      Configures hello interval
  hold-time           Configures hold time
  next-hop-self       Configures EIGRP next-hop-self
  no                  Negate a command or set its defaults
  passive-interface   Suppress address updates on an interface
  shutdown            Disable Address-Family on interface
  split-horizon       Perform split horizon
  summary-address     Perform address summarization

クラッシックモードのインタフェースレベルの設定ができます。

EIGRPインタフェースの有効化

クラッシックモードのnetworkコマンドと同様で、config-router-af モードで設定できます。

R2(config-router)# address-family ipv4 unicast autonomous-system 100
R2(config-router-af)# network 192.168.23.0 0.0.0.255

トポロジ設定

varianceコマンドなど、クラッシックモードにおけるrouter eigrpコマンド下の設定は topology baseの配下で設定できます。

R2(config-router)# address-family ipv4 unicast autonomous-system 100 
R2(config-router-af)# topology base 
R2(config-router-af-topology)# ?
Address Family Topology configuration commands:
  auto-summary         Enable automatic network number summarization
  default              Set a command to its defaults
  default-information  Control distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Define an administrative distance
  distribute-list      Filter entries in eigrp updates
  eigrp                EIGRP specific commands
  exit-af-topology     Exit from Address Family Topology configuration mode
  maximum-paths        Forward packets over multiple paths
  metric               Modify metrics and parameters for advertisement
  no                   Negate a command or set its defaults
  offset-list          Add or subtract offset from EIGRP metrics
  redistribute         Redistribute IPv4 routes from another routing protocol
  snmp                 Modify snmp parameters
  summary-metric       Specify summary to apply metric/filtering
  timers               Adjust topology specific timers
  traffic-share        How to compute traffic share over alternate paths
  variance             Control load balancing variance

以下の構成を例に、名前付きモードでAS番号の設定とnetworkコマンド設定で、R2とR3間でルート交換をします。

R2(config)# router eigrp Named-EIGRP 
R2(config-router)#  address-family ipv4 unicast autonomous-system 100 
R2(config-router-af)#   network 2.2.2.2 0.0.0.0 
R2(config-router-af)#   network 192.168.23.0 
R2(config-router-af)# exit 
R2(config-router)# exit 
R2(config)#
R3(config)# router eigrp Named-EIGRP 
R3(config-router)#  address-family ipv4 unicast autonomous-system 100 
R3(config-router-af)#   network 3.3.3.3 0.0.0.0 
R3(config-router-af)#   network 192.168.23.0 
R3(config-router-af)# exit 
R3(config-router)# exit 
R3(config)# 

%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.23.2 (FastEthernet0/0.23) 
is up: new adjacency

R2でネイバー状態を確認すると、正常にR3と隣接関係となっています。

R2# show ip eigrp neighbors  
EIGRP-IPv4 VR(Named-EIGRP) Address-Family Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.23.3            Fa0/0.23                 11 00:04:58   16   100  0  4

アドレスファミリーを指定した以下のコマンドでも同様の結果が得られます。

R2# show eigrp address-family ipv4 neighbors 
EIGRP-IPv4 VR(Named-EIGRP) Address-Family Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.23.3            Fa0/0.23                 11 00:02:19   17   102  0  7

参考

Configure EIGRP Named Mode
This document describes the named Enhanced Interior Gateway Routing Protocol (EIGRP) mode feature and discusses differences between traditional and named

コメント

タイトルとURLをコピーしました