【EIGRP】Passiveインタフェースの設定

EIGRP

EIGRPでは、networkコマンドで設定したサブネット範囲に該当するインタフェースで、EIGRPが有効となり、Helloパケットが送信されます。 ただし、EIGRPのルート広告の対象にはしたいが、Helloパケットを送信したくない場合もあります。

例えば、以下のような構成を考えます。

ここで、R2とR3でEIGRPを有効にします。

R2(config)# router eigrp 100 
R2(config-router)# network 2.2.2.2 0.0.0.0
R2(config-router)# network 192.168.12.0
R2(config-router)# network 192.168.23.0
R3(config)# router eigrp 100
R3(config-router)# network 3.3.3.3 0.0.0.0
R3(config-router)# network 192.168.23.0

%DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 192.168.23.2 (FastEthernet0/0.23) 
is up: new adjacency

R2とR3で隣接関係になりました。R3のルーティングテーブルを確認すると、R2のループバックアドレス(2.2.2.2/32)と端末接続セグメント(192.168.12.0/24)を学習しています。

R3# show ip route eigrp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 192.168.23.2, 00:10:04, FastEthernet0/0.23
D     192.168.12.0/24 
           [90/30720] via 192.168.23.2, 00:03:11, FastEthernet0/0.23

この状態で、R2でdebug eigrp packetsを実行します。

R2# debug eigrp packets 
    (UPDATE, REQUEST, QUERY, REPLY, HELLO, IPXSAP, PROBE, ACK, STUB, 
SIAQUERY, SIAREPLY)
EIGRP Packet debugging is on
R2#
*Sep 22 05:11:43.915: EIGRP: Sending HELLO on Fa0/0.23 - paklen 20
*Sep 22 05:11:43.915:   AS 100, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0
*Sep 22 05:11:43.919:   {type = 1, length = 12}
*Sep 22 05:11:43.919:   {vector = {
*Sep 22 05:11:43.923:             {01000100 0000000F}
*Sep 22 05:11:43.931:   }
*Sep 22 05:11:43.931:   {type = 4, length = 8}
*Sep 22 05:11:43.935:   {vector = {
*Sep 22 05:11:43.935:             {0A000200}
*Sep 22 05:11:43.939:   }
*Sep 22 05:11:44.787: EIGRP: Sending HELLO on Fa0/0.12 - paklen 20
*Sep 22 05:11:44.787:   AS 100, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0
*Sep 22 05:11:44.791:   {type = 1, length = 12}
*Sep 22 05:11:44.791:   {vector = {
*Sep 22 05:11:44.791:             {01000100 0000000F}
*Sep 22 05:11:44.795:   }
*Sep 22 05:11:44.795:   {type = 4, length = 8}
*Sep 22 05:11:44.795:   {vector = {
*Sep 22 05:11:44.795:             {0A000200}
*Sep 22 05:11:44.795:   }

Fa0/0.12からHelloパケットが送信されていますが、このインタフェース上のサブネットに、EIGRPが有効なルータは存在しません。Helloパケットを送信する処理が無駄であり、セキュリティ上も好ましくありません。

EIGRPのルート広告対象にするが、そのインターフェースからHelloパケットを送信しないようにするにはpassive-interfaceとして設定します。

R2(config)# router eigrp 100
R2(config-router)# passive-interface FastEthernet 0/0.12

再度、R2でdebug eigrp packetsを実行すると、Fa0/0.12からHelloパケットが送信されていないことが確認できます。

R3のルーティングテーブルを見ると、引き続き、192.168.12.0/24を学習しています。

R3# show ip route eigrp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/156160] via 192.168.23.2, 00:21:38, FastEthernet0/0.23
D     192.168.12.0/24 
           [90/30720] via 192.168.23.2, 00:14:45, FastEthernet0/0.23

debug eigrp packetsを実行すると、ループバックアドレス上ではHelloパケットが送信されていませんでした。 ただし、IOSにより動作差異があるかもしれません。

コメント

タイトルとURLをコピーしました