【DMVPN】フェーズ2をわかりやすく解説

Cisco

 DMVPNには、フェーズ1〜フェーズ3までの3つのバージョンがあります。この記事ではフェーズ2について取り上げます。フェーズ1の記事は以下を参照してください。

以下はフェーズ1とフェーズ2の差を中心に説明します。

 フェーズ2では、NHRPを使用して、スポークはハブルータに自身を登録します。ハブルータは、マルチポイントGREにより全てのスポークとGREトンネルを張ります。スポーク側はハブルータからスポークへのトンネル接続先を学習し、mGREを使用により動的にスポーク間でGREトンネルを張ることができます。これにより、スポーク間通信はハブルータを経由することはありません。

それでは以下の構成でDMVPN フェーズ2の設定、動作確認をします。

 フェーズ1ではスポーク側のトンネル接続先はハブルータをスタティックに設定しましたが、フェーズ2では、スタティック設定をせずに、マルチポイントGRE(mGRE)を有効にします。

 それぞれの設定を見ていきます。アンダーレイネットワークは、フェーズ1の記事を参照してください。ここでは割愛します。

スポンサーリンク

ハブルータ(R2)の設定

 フェーズ1の設定と全く同じです。

R2(config)#interface Tunnel0
R2(config-if)# ip address 192.168.0.2 255.255.255.0
R2(config-if)# ip nhrp authentication DMVPNPWD
R2(config-if)# ip nhrp map multicast dynamic
R2(config-if)# ip nhrp network-id 1
R2(config-if)# tunnel source 169.254.23.2
R2(config-if)# tunnel mode gre multipoint
スポンサーリンク

スポーク1(R5)の設定

 トンネル接続先をスタティックに設定せず、マルチポイントGRE(mGRE)を有効にします。

R5(config)#interface Tunnel0
R5(config-if)# ip address 192.168.0.5 255.255.255.0
R5(config-if)# ip nhrp authentication DMVPNPWD
R5(config-if)# ip nhrp map 192.168.0.2 169.254.23.2
R5(config-if)# ip nhrp map multicast 169.254.23.2
R5(config-if)# ip nhrp network-id 1
R5(config-if)# ip nhrp nhs 192.168.0.2
R5(config-if)# tunnel source 169.254.35.5
R5(config-if)# tunnel mode gre multipoint

 R2(ハブ)とR5(スポーク)の設定が終わると、トンネルインターフェースがアップします。

%LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up

 R2(ハブ)でR5(スポーク)と接続できているかshow dmvpnで確認します。

R2# show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
======================================================


Interface: Tunnel0, IPv4 NHRP Details 
Type:Hub, NHRP Peers:1, 


 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.35.5        192.168.0.5    UP 00:00:31     D

 R5のDMVPN接続状態も確認します。R2(ハブ)をNHRPのピアとして登録されています。

R5#show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
==================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:1, 


 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.23.2        192.168.0.2    UP 00:01:10     S
スポンサーリンク

スポーク2(R6)の設定

 スポーク2の設定は、スポーク1の設定からトンネルインタフェースのIPアドレスとトンネルソースのIPアドレスを変更するだけでOKです。

R6(config)#interface Tunnel0
R6(config-if)# ip address 192.168.0.6 255.255.255.0
R6(config-if)# ip nhrp authentication DMVPNPWD
R6(config-if)# ip nhrp map 192.168.0.2 169.254.23.2
R6(config-if)# ip nhrp map multicast 169.254.23.2
R6(config-if)# ip nhrp network-id 1
R6(config-if)# ip nhrp nhs 192.168.0.2
R6(config-if)# tunnel source 169.254.36.6
R6(config-if)# tunnel mode gre multipoint

 R2(ハブ)でR6(スポーク)と接続できているかshow dmvpnで確認します。

R2#show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
==============================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Hub, NHRP Peers:2, 


 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.35.5        192.168.0.5    UP 00:04:31     D
     1 169.254.36.6        192.168.0.6    UP 00:00:03     D

 R6のDMVPN接続状態も確認します。R2(ハブ)をNHRPのピアとして登録されています。

R6#show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
=================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:1, 


 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.23.2        192.168.0.2    UP 00:01:03     S

疎通試験(ハブ→スポーク)

 これで、DMVPNによるオーバーレイネットワーク(192.168.0/24)ができたはずです。 R2(ハブ)からR5、R6(スポーク)へ疎通してみます。

R2#ping 192.168.0.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/36/48 ms
R2#ping 192.168.0.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/30/56 ms

疎通試験(スポーク間)

 スポーク間、例えば、R6からR5への疎通を確認します。

R6#ping 192.168.0.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/64/148 ms

 R6のDMVPN状態を確認すると、R5へ動的のトンネルが張られていることがわかります。

R6#show dmvpn 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
===============================================
Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.23.2        192.168.0.2    UP 00:03:54     S
     1 169.254.35.5        192.168.0.5    UP 00:00:35     D

 それと合わせて、R5にも動的にトンネルが作成されています。

R5#show dmvpn  
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
        N - NATed, L - Local, X - No Socket
        # Ent --> Number of NHRP entries with same NBMA peer
        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
        UpDn Time --> Up or Down Time for a Tunnel
=================================================

Interface: Tunnel0, IPv4 NHRP Details 
Type:Spoke, NHRP Peers:2, 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb
 ----- --------------- --------------- ----- -------- -----
     1 169.254.23.2        192.168.0.2    UP 00:09:04     S
     1 169.254.36.6        192.168.0.6    UP 00:01:16     D

 このように、フェーズ2では、スポーク間通信は、動的にスポーク間でトンネルが張られるため、ハブルータを経由しません。

 最後までお読み頂きありがとうございました。

コメント

タイトルとURLをコピーしました