【OSPF】DMVPN上でOSPFを有効後、大量にエラーが出る

OSPF

 DMVPN フェーズ1上でOSPFを動作させる場合を考えます。DMVPNの構成は、以下の通りで、アンダーレイ、オーバーレイ部分の設定は以下の記事を参照してください。

スポンサーリンク

DMVPNフェーズ1上のOSPFネットワーク構成

 アンダーレイを省き、オーバーレイネットワークだけに着目します。以下のようなOSPFを構成し、各ルータにあるループバックアドレスをアドバタイズするとします。

 では、各ルータのTunnelインタフェースとLoopbackインタフェースでOSPFを有効にします。

R2(config)#router ospf 1
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 192.168.0.0 0.0.0.255 area 0
R5(config)#router ospf 1
R5(config-router)#network 5.5.5.5 0.0.0.0 area 0
R5(config-router)#network 192.168.0.0 0.0.0.255 area 0
R6(config)#router ospf 1
R6(config-router)#network 6.6.6.6 0.0.0.0 area 0
R6(config-router)#network 192.168.0.0 0.0.0.255 area 0

 すると、ハブルータであるR2で以下のエラーログが大量に出力され、ハブ〜スポーク間で、OSPF隣接関係が構築できません。

%OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 6.6.6.6 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset
%OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Tunnel0 from EXCHANGE to DOWN, 
Neighbor Down: Adjacency forced to reset

 原因はOSPFのネットワークタイプにあります。R2のOSPFネットワークタイプを確認します。

R2# show ip ospf interface  tunnel 0
Tunnel0 is up, line protocol is up 
  Internet Address 192.168.0.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 1000
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1000      no          no            Base

ネットワークタイプがpoint-to-pointであることが確認できます。これはトンネルインタフェースのデフォルトのネットワークタイプです。

point-to-pointでは、ネイバー数は1つである必要があります。R2はハブルータとして、R5,R6の2台とネイバーを張ろうとしたので、既に関係のあるネイバーは後発のOSPF要求によりリセットされ、この動作を繰り返します。

 このように、DMVPN 上で複数のスポークを接続するには、OSPFのネットワークタイプを変更する必要があります。 OSPFには、5つのネットワークタイプがあります。

  • broadcast
  • non-broadcast
  • point-to-point
  • point-to-multipoint
  • point-to-multipoint nonbroadcast

 これ以降で、DMVPN上で様々なネットワークタイプを設定することで、OSPFがどのように動作するのか記事にしていきたいと思います。

最後までお読み頂きありがとうございました。

コメント

タイトルとURLをコピーしました