【OSPF】経路集約(summary-address)

OSPF

 OSPFでは、エリア内のルート情報を集約することはできません。ただし、エリア外のルートは集約をすることができます。 エリア外ルートはABRやASBRで集約することができます。ここでは、ASBRで再配信された経路(LSAタイプ5)を集約します。

 R2のエリア0上で4つのループバックアドレスを設定し、これらを直結経路として再配信(redistribute)し、その経路を集約して、エリア23に広告します。まず、集約前の基本設定をします。

R2(config-if)# interface Loopback100
R2(config-if)# ip address 172.16.0.1 255.255.255.0
R2(config-if)# interface Loopback101
R2(config-if)# ip address 172.16.1.1 255.255.255.0
R2(config-if)# interface Loopback102
R2(config-if)# ip address 172.16.2.1 255.255.255.0
R2(config-if)# interface Loopback103
R2(config-if)# ip address 172.16.3.1 255.255.255.0

R2(config)# router ospf 1
R2(config-router)# redistribute connected subnets
R2(config-router)# network 192.168.23.0 0.0.0.255 area 0
R3(config)# router ospf 1
R3(config-router)# network 192.168.23.0 0.0.0.255 area 0

R3でR2の4つのループバックへの経路が確認できます。

R3# show ip route ospf

      172.16.0.0/24 is subnetted, 4 subnets
O E2     172.16.0.0 [110/20] via 192.168.23.2, 00:02:22, FastEthernet0/0.23
O E2     172.16.1.0 [110/20] via 192.168.23.2, 00:02:22, FastEthernet0/0.23
O E2     172.16.2.0 [110/20] via 192.168.23.2, 00:02:22, FastEthernet0/0.23
O E2     172.16.3.0 [110/20] via 192.168.23.2, 00:02:22, FastEthernet0/0.23

 R3のLSDBの中身を確認すると、LSAタイプ5(Type-5 AS External Link)として、4つのループバックへの経路が登録されています。

R3# show ip ospf database 

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         174         0x80000003 0x0046D2 1
3.3.3.3         3.3.3.3         173         0x80000002 0x00040F 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    3.3.3.3         173         0x80000001 0x004254

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
172.16.0.0      2.2.2.2         199         0x80000001 0x0026B5 0
172.16.1.0      2.2.2.2         199         0x80000001 0x001BBF 0
172.16.2.0      2.2.2.2         199         0x80000001 0x0010C9 0
172.16.3.0      2.2.2.2         199         0x80000001 0x0005D3 0

 この172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24を集約したセグメントは 172.16.0.0/22となります。では、R2でLSAタイプ5の経路を集約します。コマンドはsummary-addressコマンドを使用します。

R2(config)# router ospf 1
R2(config-router)# summary-address 172.16.0.0 255.255.252.0

 R3のルーティングテーブルを確認します。

R3# show ip route ospf

      172.16.0.0/22 is subnetted, 1 subnets
O E2     172.16.0.0 [110/20] via 192.168.23.2, 00:00:16, FastEthernet0/0.23

 LSDBの中身を確認すると、LSAタイプ5(Type-5 AS External Link)として、4つのループバック経路が1つに集約されていることが確認できます。

R3# show ip ospf database 

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
2.2.2.2         2.2.2.2         236         0x80000003 0x0046D2 1
3.3.3.3         3.3.3.3         235         0x80000002 0x00040F 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    3.3.3.3         235         0x80000001 0x004254

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
172.16.0.0      2.2.2.2         28          0x80000003 0x0013C9 0

このように集約することで、LSDBのサイズを小さくすることができます。 特に大規模なネットワークで、多数の経路情報を保持するようなネットワークでOSPFを使用する場合は、経路集約を検討することがよくあります。

コメント

タイトルとURLをコピーしました