【OSPF】マルチアクセス環境(DR/BDR)

OSPF
スポンサーリンク

マルチアクセス環境でのLSA交換の問題点

 基本的には、LSAはルータ間を1対1(ポイントトゥポイント)で交換されます。

 ただし、マルチアクセス環境で1対1でのLSA交換をすると、ルータ間の交換パスが増え、ルート情報更新に負荷がかかります。

スポンサーリンク

代表ルータ(DR)とは

 代表ルータはイーサネットなどマルチアクセスセグメントで、ルート情報更新の負荷を軽減する役割をはたします。 OSPFが有効なインタフェースのイーサネットセグメント内から代表ルータ(Designated Router :DR)が1台選出されます。

 バックアップ代表ルータ(BDR)は、現在のDRがネットワーク上で障害が発生した場合にDRに昇格するルータです。

 DRは擬似ノードとして扱われ、各ルータはDRとLSAを1対1(ポイントトゥポイント)で交換します。

スポンサーリンク

DR/BDRの選出

 OSPFルータ優先度が最も大きい値のHelloパケットを送信しているルータがDRに選出されます。 優先度が 0 に設定されている場合、DR や BDR になることはできません。 2 つ以上のルータが最高の優先度設定で同点の場合は、最高のルータ ID を持つ Hello を送信するルータがDRに選出されます。 DRが選出されたのちに、DRより優先度の高い OSPF ルータが接続されても、既存の DR または BDR が障害になるまで、そのルータは、DR または BDR にはなりません。

基本設定と確認

基本設定

 OSPFを有効にしたいインタフェースとエリア番号をnetworkコマンドで設定します。

R1(config)#router ospf 1
R1(config-router)#network 192.168.123.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R2(config)#router ospf 1
R2(config-router)#network 192.168.123.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R3(config)#router ospf 1
R3(config-router)#network 192.168.123.0 0.0.0.255 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0

 DR・BDRと隣接関係になると、以下のようなコンソールログが出力されます。

R1#
%OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet0/0.123 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/0.123 from LOADING to FULL, Loading Done

動作確認

インタフェース確認

 OSPFが有効なインタフェースをshow ip ospf interfaceコマンドで確認します。 OSPFが有効なインタフェースで、Helloパケットの送信間隔や隣接関係を結んでいるDR,BDRが確認できます。

R1#show ip ospf interface 
Loopback0 is up, line protocol is up  
  Internet Address 1.1.1.1/32, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Loopback interface is treated as a stub Host
FastEthernet0/0.123 is up, line protocol is up 
  Internet Address 192.168.123.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 3.3.3.3, Interface address 192.168.123.3 
  Backup Designated router (ID) 2.2.2.2, Interface address 192.168.123.2 
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:00
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 2, Adjacent neighbor count is 2 
    Adjacent with neighbor 2.2.2.2  (Backup Designated Router)
    Adjacent with neighbor 3.3.3.3  (Designated Router)
  Suppress hello for 0 neighbor(s)

ネイバー情報の確認

 マルチアクセスセグメントのどのルータと隣接関係になっているのかshow ip ospf neighborで確認できます。 R1から見て、R3 (3.3.3.3) がDR、R2 (2.2.2.2) がBDRであることがわかります。

R1#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           1   FULL/BDR        00:00:36    192.168.123.2   FastEthernet0/0.123
3.3.3.3           1   FULL/DR         00:00:31    192.168.123.3   FastEthernet0/0.123

 R2から見ると、R1(1.1.1.1)はDRでもBDRでもないため、DROTHERと表示されます。

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DROTHER    00:00:39    192.168.123.1   FastEthernet0/0.123
3.3.3.3           1   FULL/DR         00:00:32    192.168.123.3   FastEthernet0/0.123

ルーティングテーブルの確認

 R1にて、R2やR3のループバックアドレスを学習していることが確認できます。

R1#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set


      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 192.168.123.2, 00:08:03, FastEthernet0/0.123
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 192.168.123.3, 00:07:49, FastEthernet0/0.123

コメント

タイトルとURLをコピーしました