【OSPF】スタブエリアの設定

OSPF

 OSPFには、スタブエリアと呼ばれる特別なエリアタイプがあり、OSPF外部ルート(LSA5)の代わりにデフォルトルートを挿入します。これにより、LSDBが小さくなり、ルーティングテーブルも小さくなります。

スポンサーリンク

スタブエリア設定

基本設定

 R1からR3で図の通りOSPFを有効にします。外部ルートを生成するため、R3ではループバックアドレス3.3.3.3を直結経路としてOSPFへ再配信(redistribute)します。

R1(config)# router ospf 1
R1(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config)# router ospf 1
R2(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 192.168.23.0 0.0.0.255 area 0
R3(config)# router ospf 1
R3(config-router)# redistribute connected subnets
R3(config-router)# network 192.168.23.0 0.0.0.255 area 0

 R1のルーティングテーブルを確認します。3.3.3.3が外部ルート(O E2) 、2.2.2.2がエリア間ルート(O IA)であることが確認できます。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12
      3.0.0.0/32 is subnetted, 1 subnets
O E2      3.3.3.3 [110/20] via 192.168.12.2, 00:05:45, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12

スタブ設定

 エリア12をスタブエリアに設定します。

R1(config)# router ospf 1
R1(config-router)# area 12 stub
R2(config)# router ospf 1
R2(config-router)# area 12 stub

 これでスタブ設定は完了です。スタブエリアの場合、R1とR2間のHelloパケットで、Eビット(External Routing)がゼロになっていることが確認できます。

スポンサーリンク

確認

設定の確認

 show ip protocolsにより、設定された通常エリア、スタブエリアの数が確認できます。

R1# show ip protocols 
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 0 normal 1 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.1.1 0.0.0.0 area 12
    192.168.12.0 0.0.0.255 area 12
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      00:23:08
    2.2.2.2              110      00:15:41
  Distance: (default is 110)

 show ip ospfでは、Area12がスタブエリアであることが確認できます。

R1# show ip ospf 
 Routing Process "ospf 1" with ID 1.1.1.1
 Start time: 00:01:14.340, Time elapsed: 02:53:55.352

〜 省略

    Area 12
        Number of interfaces in this area is 2 (1 loopback)
        It is a stub area
        Area has no authentication
        SPF algorithm last executed 00:12:17.136 ago
        SPF algorithm executed 11 times
        Area ranges are
        Number of LSA 6. Checksum Sum 0x02797E
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ルーティングテーブル確認

 R1のルーティングテーブルを確認します。外部ルート(O E2)がブロックされ、その代わりにデフォルトルートがR2から広告されています。エリア間ルート(O*IA)は、ブロックされていません。

R1# show ip route  ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.12.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/2] via 192.168.12.2, 00:16:58, FastEthernet0/0.12
      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:16:58, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:16:58, FastEthernet0/0.12
スポンサーリンク

スタブエリアにASBRを含めることができない

 スタブエリアの制限として、スタブエリア内にはASBR(Autonomous System Boundary Router)を含めることはできません。 ASBRは、OSPF以外のルーティングプロトコルを再配信するルータのことです。

 R1でループバックアドレス1.1.1.1を直結経路としてOSPFに再配信してみます。

R1(config)# router ospf 1
R1(config-router)# redistribute connected subnets

 すると、以下のように、スタブエリア内にASBRが含まれているエラーログが出力されます。

*Jun 19 05:05:38.267: %OSPF-4-ASBR_WITHOUT_VALID_AREA: Router is currently 
an ASBR while having only one area which is a stub area

 R1とR2間のネイバーは維持されますが、R1で再配信設定した直結経路(1.1.1.1)は、R2に広告されません。

コメント

タイトルとURLをコピーしました