【OSPF】NSSAの設定

OSPF

 スタブエリア内にはASBRを含めることができないため、スタブエリアから外部ルートを挿入することはできませんでした。 もし、スタブエリア内のルータから外部ルート(再配信)を挿入する必要がある場合は、そのエリアをNot So Stubby Area (NSSA)にする必要があります。 外部ルートがタイプ7のLSAとしてスタブエリアを経由して運ばれ、ABRはそれらをタイプ5に変換し、他エリアへLSAを伝播します。

スポンサーリンク

NSSA設定

基本設定

 R1からR3で図の通りOSPFを有効にします。外部ルートを生成するため、R3ではループバックアドレス3.3.3.3を直結経路としてOSPFへ再配信(redistribute)します。

R1(config)# router ospf 1
R1(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config)# router ospf 1
R2(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 192.168.23.0 0.0.0.255 area 0
R3(config)# router ospf 1
R3(config-router)# redistribute connected subnets
R3(config-router)# network 192.168.23.0 0.0.0.255 area 0

 R1のルーティングテーブルを確認します。3.3.3.3が外部ルート(O E2) 、2.2.2.2がエリア間ルート(O IA)であることが確認できます。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12
      3.0.0.0/32 is subnetted, 1 subnets
O E2      3.3.3.3 [110/20] via 192.168.12.2, 00:05:45, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12

NSSA設定

 エリア12をNSSAに設定します。

R1(config)# router ospf 1
R1(config-router)# area 12 nssa
R2(config)# router ospf 1
R2(config-router)# area 12 nssa

 これでNSSA設定は完了です。NSSAの場合、R1とR2間のHelloパケットで、Eビット(External Routing)がゼロであることと合わせ、Nビット(NSSA)が1になっています。

スポンサーリンク

確認

設定の確認

 show ip ospfで、Area12がNSSAであることが確認できます。

R1# show ip ospf
Routing Process "ospf 1" with ID 1.1.1.1

〜 省略

    Area 12
        Number of interfaces in this area is 1
        It is a NSSA area
        Area has no authentication
        SPF algorithm last executed 00:01:21.088 ago
        SPF algorithm executed 27 times
        Area ranges are
        Number of LSA 5. Checksum Sum 0x02B356
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ルーティング確認

ルーティングテーブル確認

 R1のルーティングテーブルを確認します。外部ルート(LSA5)がブロックされているため、3.3.3.3への経路がなくなっています。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:00:23, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:00:23, FastEthernet0/0.12

 スタブエリアの場合は、外部プレフィックス(LSA5)をブロックし、デフォルトルートが挿入されましたが、今回はデフォルトルートがありません。

デフォルトルート配信設定

 NSSA内ルータは外部ルートを任意に挿入できるため、デフォルトルートをどこから配信するかは、手動で設定する必要があります。 ここでは、R2からデフォルトルートを挿入します。

R2(config)# router ospf 1
R2(config-router)# area 12 nssa default-information-originate

 R1のルーティングテーブルを確認します。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.12.2 to network 0.0.0.0

O*N2  0.0.0.0/0 [110/1] via 192.168.12.2, 00:00:35, FastEthernet0/0.12
      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:05:53, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:05:53, FastEthernet0/0.12

 O*N2としてデフォルトルートが配信されていることが確認できます。

NSSA内でASBRを設定

 R1から外部経路としてループバック(1.1.1.1/32)をNSSAへ挿入します。

R1(config)# router ospf 1
R1(config-router)# redistribute connected subnets

 スタブエリアの時は %OSPF-4-ASBR_WITHOUT_VALID_AREA のエラーが出ましたが、今回は出力されません。

 R2のルーティングテーブルを確認します。 O N2 として、1.1.1.1と認識してます。これは、LSAタイプ7で学習したルートです。

R2# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O N2     1.1.1.1 [110/20] via 192.168.12.1, 00:01:25, FastEthernet0/0.12
      3.0.0.0/32 is subnetted, 1 subnets
O E2     3.3.3.3 [110/20] via 192.168.23.3, 00:03:23, FastEthernet0/0.23

 R3のルーティングテーブルを確認します。 O E2 として、1.1.1.1と認識しています。これは、LSAタイプ5で学習したルートです。R2で1.1.1.1のルート情報が、LSAタイプ7からタイプ5へ変換されています。

R3# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O E2     1.1.1.1  [110/20] via 192.168.23.2, 00:02:20, FastEthernet0/0.23
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 192.168.23.2, 03:47:45, FastEthernet0/0.23
O IA  192.168.12.0/24 [110/2] via 192.168.23.2, 03:47:45, FastEthernet0/0.23

 

コメント

タイトルとURLをコピーしました