【OSPF】トータリスタブエリアの設定

OSPF

 OSPFには、スタブエリアの拡張としてトータリスタブエリアと呼ばれる特別なエリアタイプがあります。これは、OSPF外部ルート(LSA5)に加えてエリア間ルート(LSA3)の経路もデフォルトルートに置き換えて、エリア内に挿入します。これにより、さらにLSDBが小さくなり、ルーティングテーブルも小さくなります。

スポンサーリンク

トータリスタブエリア設定

基本設定

 R1からR3で図の通りOSPFを有効にします。外部ルートを生成するため、R3ではループバックアドレス3.3.3.3を直結経路としてOSPFへ再配信(redistribute)します。

R1(config)# router ospf 1
R1(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config)# router ospf 1
R2(config-router)# network 192.168.12.0 0.0.0.255 area 12
R2(config-router)# network 2.2.2.2 0.0.0.0 area 0
R2(config-router)# network 192.168.23.0 0.0.0.255 area 0
R3(config)# router ospf 1
R3(config-router)# redistribute connected subnets
R3(config-router)# network 192.168.23.0 0.0.0.255 area 0

 R1のルーティングテーブルを確認します。3.3.3.3が外部ルート(O E2) 、2.2.2.2がエリア間ルート(O IA)であることが確認できます。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O IA     2.2.2.2 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12
      3.0.0.0/32 is subnetted, 1 subnets
O E2      3.3.3.3 [110/20] via 192.168.12.2, 00:05:45, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:06:30, FastEthernet0/0.12

トータリスタブ設定

 エリア12をトータリスタブエリアに設定します。 no-summary がトータリスタブエリアに必要な設定です。設定はABRであるR2のみで問題ありません。

R1(config)# router ospf 1
R1(config-router)# area 12 stub 
R2(config)# router ospf 1
R2(config-router)# area 12 stub no-summary
スポンサーリンク

確認

設定の確認

 show ip ospfで、Area12にno summaryがあり、トータリスタブエリアであることが確認できます。

R2# show ip ospf 
 Routing Process "ospf 1" with ID 2.2.2.2

〜 省略

    Area 12
        Number of interfaces in this area is 1
        It is a stub area, no summary LSA in this area
        Generates stub default route with cost 1
        Area has no authentication
        SPF algorithm last executed 00:00:31.364 ago
        SPF algorithm executed 16 times
        Area ranges are
        Number of LSA 4. Checksum Sum 0x01D557
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

ルーティングテーブル確認

 R1のルーティングテーブルを確認します。外部ルート(O E2)の経路と合わせて、エリア間ルート(O IA)もブロックされ、その代わりにデフォルトルートがR2から広告されています。

R1# show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 192.168.12.2 to network 0.0.0.0

O*IA  0.0.0.0/0 [110/2] via 192.168.12.2, 00:01:43, FastEthernet0/0.12

 

コメント

タイトルとURLをコピーしました