【OSPF】経路集約(area range)設定

OSPF

 OSPFでは、エリア内のルート情報を集約することはできません。ただし、エリア外のルートは集約をすることができます。 エリア外ルートはABRやASBRで集約することができます。ここでは、ABRでLSAタイプ3の経路を集約します。

 R2のエリア0上で4つのループバックアドレスを設定し、これを集約して、エリア23に広告します。まず、集約前の基本設定をします。

R2(config)# interface Loopback100
R2(config-if)# ip address 172.16.0.1 255.255.255.0
R2(config-if)#interface Loopback101
R2(config-if)# ip address 172.16.1.1 255.255.255.0
R2(config-if)#interface Loopback102
R2(config-if)# ip address 172.16.2.1 255.255.255.0
R2(config-if)#interface Loopback103
R2(config-if)#ip address 172.16.3.1 255.255.255.05t 

R2(config)#router ospf 1
R2(config-router)# network 172.16.0.0 0.0.0.255 area 0
R2(config-router)# network 172.16.1.0 0.0.0.255 area 0
R2(config-router)# network 172.16.2.0 0.0.0.255 area 0
R2(config-router)# network 172.16.3.0 0.0.0.255 area 0
R2(config-router)# network 192.168.23.0 0.0.0.255 area 23
R3(config)#router ospf 1
R3(config-router)# network 192.168.23.0 0.0.0.255 area 23

 R3でR2の4つのループバックへの経路が確認できます。

R3#show ip route ospf

      172.16.0.0/32 is subnetted, 4 subnets
O IA     172.16.0.1 [110/2] via 192.168.23.2, 00:00:05, FastEthernet0/0.23
O IA     172.16.1.1 [110/2] via 192.168.23.2, 00:00:05, FastEthernet0/0.23
O IA     172.16.2.1 [110/2] via 192.168.23.2, 00:00:05, FastEthernet0/0.23
O IA     172.16.3.1 [110/2] via 192.168.23.2, 00:00:05, FastEthernet0/0.23

 R3のLSDBの中身を確認すると、LSAタイプ3(Summary Net Link)として、4つのループバックへの経路が登録されています。

R3#show ip ospf database 

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum Link count
3.3.3.3         3.3.3.3         261         0x80000002 0x00F91A 1
172.16.3.1      172.16.3.1      262         0x80000002 0x007535 1

                Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.2    172.16.3.1      262         0x80000001 0x002307

                Summary Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.0.1      172.16.3.1      4           0x80000001 0x005667
172.16.1.1       172.16.3.1      4           0x80000001 0x004B71
172.16.2.1       172.16.3.1      4           0x80000001 0x00407B
172.16.3.1       172.16.3.1      4           0x80000001 0x003585

 この172.16.0.0/24、172.16.1.0/24、172.16.2.0/24、172.16.3.0/24を集約したセグメントは 以下の通り172.16.0.0/22となります。

172.16.0.0/24     10101100.00010000.00000000.00000000
172.16.1.0/24     10101100.00010000.00000001.00000000
172.16.2.0/24     10101100.00010000.00000010.00000000
172.16.2.0/24     10101100.00010000.00000011.00000000
   ↓
172.16.0.0/22     10101100.00010000.00000000.00000000  

 では、R2でLSAタイプ3の経路を集約します。コマンドはarea rangeコマンドを使用します。

R2(config)#router ospf 1
R2(config-router)#area 0 range 172.16.0.0 255.255.252.0

R3のルーティングテーブルを確認します。

R3#show ip route ospf

      172.16.0.0/22 is subnetted, 1 subnets
O IA     172.16.0.0 [110/2] via 192.168.23.2, 00:00:10, FastEthernet0/0.23

 LSDBの中身を確認すると、LSAタイプ3(Summary Net Link)として、4つのループバック経路が1つに集約されていることが確認できます。

R3#show ip ospf database 

            OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum Link count
3.3.3.3         3.3.3.3         233         0x80000002 0x00F91A 1
172.16.3.1      172.16.3.1      234         0x80000002 0x007535 1

                Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.2    172.16.3.1      234         0x80000001 0x002307

                Summary Net Link States (Area 23)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.0.0      172.16.3.1      53          0x80000001 0x005170

このように集約することで、LSDBのサイズを小さくすることができます。 特に大規模なネットワークで、多数の経路情報を保持するようなネットワークでOSPFを使用する場合は、経路集約を検討することがよくあります。

コメント

タイトルとURLをコピーしました