【OSPF】仮想リンク(Virtual-link)

OSPF

 OSPFでは、すべてのエリアがバックボーンエリア(エリア0)に直接接続されている必要があります。以下のような構成を考えます。

 3つのエリアがあり、左側がエリア0です。エリア34はエリア23の背後にあり、エリア0には直接接続されていません。まず、この構成で各インタフェースのOSPFを有効にします。

R1(config)#router ospf 1
R1(config-router)# network 1.1.1.1 0.0.0.0 area 0
R1(config-router)# network 192.168.12.0 0.0.0.255 area 0
R2(config)#router ospf 1
R2(config-router)# network 192.168.12.0 0.0.0.255 area 0
R2(config-router)# network 192.168.23.0 0.0.0.255 area 23
R3(config)#router ospf 1
R3(config-router)# network 192.168.23.0 0.0.0.255 area 23
R3(config-router)# network 192.168.34.0 0.0.0.255 area 34
R4(config)#router ospf 1
R4(config-router)# network 4.4.4.4 0.0.0.0 area 34
R4(config-router)# network 192.168.34.0 0.0.0.255 area 34

 では、エリア0にあるR1のルーティングテーブルを確認します。

R1#show ip route ospf

O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:04:46, FastEthernet0/0.12

 エリア0に直接接続しているエリア23内のネットワーク192.168.23.0/24のみエリア間ルート(OIA)として学習しています。エリア23の先にあるエリア34内のネットワーク情報は学習していません。

 また、R4のルーティングテーブルを確認します。

R4#show ip route ospf

R4#

 R4はOSPFのルートが一つもありません。

 このように、エリア0以外の間でエリア間ルート(LSAタイプ3)のやりとりはしません。

 このような構成で、エリア0のR1がエリア34の経路情報を学習するには、仮想リンクを使用する必要があります。仮想リンクはエリア0に属するポイントツーポイント接続で、これらは2つのABR間でのみ作成可能です。

 今回は、エリア34をエリア0にリンクする必要があるので、R2とR3間で仮想リンクを張ります。

 ABR間の仮想リンクを設定するには、area virtual-linkコマンドを使用します。

仮想リンクの張り先はルータIDであることが重要です。

 今回の構成では、R2とR3のルータIDは、それぞれループバックアドレスである、2.2.2.2 と3.3.3.3としています。

R2(config)#router ospf 1
R2(config-router)#area 23 virtual-link 3.3.3.3
R3(config)#router ospf 1
R3(config-router)#area 23 virtual-link 2.2.2.2

 しばらくすると、仮想リンク上で、隣接状態が確立されます。

R2
%OSPF-5-ADJCHG:Process 1,Nbr 3.3.3.3 on OSPF_VL0 from LOADING to FULL,Loading Done
R3
%OSPF-5-ADJCHG:Process 1,Nbr 2.2.2.2 on OSPF_VL0 from LOADING to FULL,Loading Done

 R2のネイバー状態を確認すると、R3に対して、OSPF_VL0経由で隣接関係であることがわかります。

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -           -        192.168.23.3    OSPF_VL0
1.1.1.1           1   FULL/DR         00:00:36    192.168.12.1    FastEthernet0/0.12
3.3.3.3           1   FULL/DR         00:00:34    192.168.23.3    FastEthernet0/0.23
R3#show ip ospf neighbor  

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -           -        192.168.23.2    OSPF_VL0
2.2.2.2           1   FULL/BDR        00:00:38    192.168.23.2    FastEthernet0/0.23
4.4.4.4           1   FULL/DR         00:00:37    192.168.34.4    FastEthernet0/0.34

 仮想リンクの状態は show ip ospf virtual-links で確認します。

R2#show ip ospf virtual-links 
Virtual Link OSPF_VL0 to router 3.3.3.3 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 23, via interface FastEthernet0/0.23
 Topology-MTID    Cost    Disabled     Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
    Adjacency State FULL (Hello suppressed)
    Index 2/3, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec

 仮想リンクはPOINT_TO_POINTリンクとして扱われます。LSDBの同期完了後、仮想リンク上では、Helloパケットは抑止されます。これは、Run as demand circuitの意味です。何らかのトポロジの変更時のみ、仮想リンクを介して、LSAがフラッディングされます。また、仮想リンク上で交換されるLSAはDoNotAgeビットが立っていて、LSDBの有効期限切れはありません。

 R1のルーティングテーブルを見ると、エリア34内の経路(4.4.4.4と192.168.34.0)を学習していることがわかります。

R1#show ip route ospf
      4.0.0.0/32 is subnetted, 1 subnets
O IA     4.4.4.4 [110/4] via 192.168.12.2, 00:11:25, FastEthernet0/0.12
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:47:06, FastEthernet0/0.12
O IA  192.168.34.0/24 [110/3] via 192.168.12.2, 00:11:25, FastEthernet0/0.12

 次にR4のルーティングテーブルを見ると、エリア0やエリア23内の経路(1.1.1.1、192.168.12.0、192.168.23.0)を学習していることがわかります。

R4#show ip route ospf
      1.0.0.0/32 is subnetted, 1 subnets
O IA     1.1.1.1 [110/4] via 192.168.34.3, 00:12:43, FastEthernet0/0.34
O IA  192.168.12.0/24 [110/3] via 192.168.34.3, 00:12:43, FastEthernet0/0.34
O IA  192.168.23.0/24 [110/2] via 192.168.34.3, 00:12:48, FastEthernet0/0.34

コメント

タイトルとURLをコピーしました