【NAT】ダイナミックNAT

Cisco
スポンサーリンク

ダイナミックNAT

 NAT変換する際の、変換後のIPアドレス範囲をプールアドレスとして指定する設定を確認します。 R2に複数のアドレス(192.168.23.2 , 192.168.23.22, 192.168.23.222)を設定し、それぞれのアドレスからR4(192.168.34.4)に接続し、設定したプールアドレスを使用しながら、アドレス変換されてことを確認します。

スポンサーリンク

設定

 まず、R3のインターフェースでNATの内部と外部を定義します。

R3(config)# interface FastEthernet0/0.23 
R3(config-subif)# ip nat inside
R3(config-subif)# exit
R3(config)# interface FastEthernet0/0.34
R3(config-subif)# ip nat outside

 次に、変換に使用できるIPアドレスを持つプールを作成します。ip nat poolコマンドでプールを作成できます。プールの名前は、NATPOOLとし、IPアドレス192.168.34.100 から192.168.34.200までを使用します。

R3(config)# ip nat pool NATPOOL 192.168.34.100 192.168.34.200 prefix-length 24

 次に、送信元となるNAT内部のアドレスをアクセスリストで定義します。今回は、アクセスリスト1とし192.168.23.0/24を設定します。

R3(config)# access-list 1 permit 192.168.23.0 0.0.0.255

 最後にアクセスリストとプールを紐付けます。

R3(config)# ip nat inside source list 1 pool NATPOOL

 設定を前から順番に、ip natinsideで受信したsourceのアドレスをlist 1からNATPOOLに変換します という設定です。

スポンサーリンク

確認

まず、R2に複数のIPアドレスとデフォルトルートを設定します。

R2(config)# int fa0/0.23
R2(config-subif)# ip address 192.168.23.2 255.255.255.0 
R2(config-subif)# ip address 192.168.23.22 255.255.255.0 secondary 
R2(config-subif)# ip address 192.168.23.222 255.255.255.0 secondary 
R2(config-subif)# exit
R2(config)# ip route 0.0.0.0 0.0.0.0 192.168.23.3

 では、R2からR4へPingを実行します。

R2# ping 192.168.34.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 100/208/352 ms

 R3のNATテーブルを確認します。

R3# sh ip nat translations 
Pro Inside global      Inside local       Outside local      Outside global
icmp 192.168.34.100:3  192.168.23.2:3     192.168.34.4:3     192.168.34.4:3
--- 192.168.34.100     192.168.23.2       ---                —

 続けて、R2から送信元アドレスを192.168.23.22, 192.168.23.222に変更して、R4へPingを実行します。

R2# ping 192.168.34.4 source 192.168.23.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.34.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.23.22 
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 180/221/248 ms
R2# ping 192.168.34.4 source 192.168.23.222
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.34.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.23.222 
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 100/243/456 ms

 ここで、R3のNATテーブルを確認します。

R3# sh ip nat translations    
Pro Inside global      Inside local       Outside local      Outside global
icmp 192.168.34.100:7  192.168.23.2:7     192.168.34.4:7     192.168.34.4:7
--- 192.168.34.100     192.168.23.2       ---                ---
icmp 192.168.34.101:8  192.168.23.22:8    192.168.34.4:8     192.168.34.4:8
--- 192.168.34.101     192.168.23.22      ---                ---
icmp 192.168.34.102:9  192.168.23.222:9   192.168.34.4:9     192.168.34.4:9
--- 192.168.34.102     192.168.23.222     ---                ---

 それぞれの送信元アドレスに対して、Inside Global(NATを実行しているルーターの外部インターフェイスのIPアドレス)がプールアドレスの範囲から192.168.34.100 、192.168.34.101、192.168.34.102と順番に使われます。

コメント

タイトルとURLをコピーしました