【超基本】VLANとは(仮想LAN)

Cisco
スポンサーリンク

VLANとは

 VLAN(仮想LAN)は、同じ物理機器(LANスイッチなど)に接続されているネットワークを(仮想的に)複数のLANセグメントへ分割する技術です。VLANを利用することで、同じスイッチに接続されているより多くの機器(PCやプリンタなど)を(論理的な観点から)分離することができます。VLANはネットワークセグメントを表しています。2つのVLANを作成した場合、2つの異なるネットワークセグメント(ブロードキャストドメイン)を持つことになります。

 VLANはVLAN番号と言われる一意のID(識別番号)によって区別されます。 Ciscoスイッチの場合、IDには大きく分けて、2つのカテゴリがあります。

  • 標準 VLAN ID  1~1005 
  • 拡張 VLAN ID  1006~4094

 例えば、192.168.1.0/24のVLAN番号を100, 192.168.2.0/24のVLAN番号を200というようにして、サブネットを識別します。

スポンサーリンク

IEEE802.1q (タグVLAN)

 例えば、2台のスイッチ間をケーブル接続して、VLAN100とVLAN200に所属する端末が接続できるようにしたいとします。 スイッチ間の接続で、すぐに思いつくのは、スイッチそれぞれのVLAN同士を物理的にケーブル接続することです。

 これでも接続はできますが、例えば、スイッチにVLANが100個あったらケーブルを100本接続しないといけません。スイッチは基本、24ポートや48ポートなど、数には限界があります。そこで、1つの物理ポートに複数のVLANを多重化する仕組みが必要になります。これが、IEEE802.1qによるタグVLANです

 また、上記のように、端末などが接続されるポートをアクセスポートといい、スイッチ間など、複数のVLANを多重化しているポートをトランクポートといます。

スポンサーリンク

設定例

 以下の構成で、スイッチの設定を確認します。スイッチ2台とも、同じ設定です。

VLAN設定

   VLAN100とVLAN200を設定します。

SW1(config)# vlan 100
SW1(config-vlan)# exit
SW1(config)# vlan 200
SW1(config-vlan)# exit

コマンドshow vlan でVLANが追加されているかどうか確認できます。

SW1# show vlan


VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                               
100   VLAN0010                         active    
200    VLAN0020                         active   

アクセスポートの設定

 Fa0/1をVLAN100, Fa0/2をVLAN200のアクセスポートとして設定します。

SW1(config)# interface FastEthernet0/1
SW1(config-if)# switchport access vlan 100
SW1(config-if)# switchport mode access

SW1(config)# interface FastEthernet0/2
SW1(config-if)# switchport mode access 
SW1(config-if)# switchport access vlan 200

 各VLANのポート割り当て状況を確認します。

SW1# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, 
                                               
100   VLAN0010                         active   Fa0/1  
200   VLAN0020                         active   Fa0/2 

 また、ポートに対して、どのVLANが設定されているかを show interface status で確認します。

SW1# show interface status

Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    100          a-full  a-100 100BaseTX/FX
Fa0/2                        connected    200          a-full  a-100 100BaseTX/FX

トランクポートの設定

 Fa0/8をトランクポートとして設定します。

SW1(config)# interface FastEthernet0/8
SW1(config-if)# switchport trunk encapsulation dot1q 
SW1(config-if)# switchport mode trunk 
SW1(config-if)# switchport trunk allowed vlan 100,200

 最後の allowed vlan を設定しないと、トランクポートには、設定している全てのVLANが、多重化されます。 実務上では、余計なVLANをトランクポートの対象にしないように、allowed vlanを設定し、対象VLANを制限します。

 では、Fa0/8がトランクポートとして、どのVLAN番号を許可されているのかを確認します。

SW1# show int trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/8       on               802.1q         trunking      1


Port        Vlans allowed on trunk
Fa0/8       100,200


Port        Vlans allowed and active in management domain
Fa0/8       100,200


Port        Vlans in spanning tree forwarding state and not pruned
Fa0/8       100,200

ポートがトランクか否かだけであれば、show interface status でも確認できます。

SW1# show interface status


Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    100         a-full  a-100 100BaseTX/FX
Fa0/2                        connected    200         a-full  a-100 100BaseTX/FX

Fa0/8                        connected    trunk       a-full  a-100 100BaseTX/FX

 最後までお読み頂きありがとうございました。

コメント

タイトルとURLをコピーしました